Thai Mikrotik User Club
พฤศจิกายน 01, 2014, 05:38:00 AM *
ยินดีต้อนรับคุณ, บุคคลทั่วไป กรุณา เข้าสู่ระบบ หรือ ลงทะเบียน
ส่งอีเมล์ยืนยันการใช้งาน?

เข้าสู่ระบบด้วยชื่อผู้ใช้ รหัสผ่าน และระยะเวลาในเซสชั่น
ข่าว: ยินดีต้อนรับ Networker ทุกท่าน
 
   หน้าแรก   ช่วยเหลือ เข้าสู่ระบบ สมัครสมาชิก  
หน้า: [1] 2
  ส่งหัวข้อนี้  |  พิมพ์  
ผู้เขียน หัวข้อ: ตั้งค่าให้สามารถเข้าหน้า config ของ modem ไ  (อ่าน 4917 ครั้ง)
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« เมื่อ: กุมภาพันธ์ 21, 2010, 01:56:25 PM »

ระบบของผม Set เป็น PPPoE Client ผ่าน Modem ADSL
ต้องการให้สามารถ เข้าไปหน้า Config ของ modem ได้ครับ
modem => 192.168.1.1
LAN => 192.168.2.0/24

เคยใช้ Tomato ใช้ script ตามนี้ครับ
ip addr add 192.168.1.2/24 dev vlan1 brd +
/usr/sbin/iptables -I POSTROUTING -t nat -o vlan1 -d 192.168.1.0/24 -j MASQUERADE

ลองเลียนแบบแล้ว ยังไม่ผ่านเลยครับ
บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #1 เมื่อ: มีนาคม 05, 2010, 12:31:31 AM »

ไม่มีใครเลยทำเลยเหรอครับ
ดูแล้วเป็นเรื่องง่ายๆ แต่ทำไม ผมเข้าไม่ได้ก็ไม่รู้ ฮืม
บันทึกการเข้า
CommanddeR
บุคคลทั่วไป
« ตอบ #2 เมื่อ: มีนาคม 05, 2010, 01:21:27 AM »

อืมม มันก็ได้นะครับ
พอดีง่วงแล้ว ขอบอกแบบไม่มีตัวอย่างแล้วกัน
1. ทำให้ mikrotik เห็น modem ก่อน จะด้วยวิธี ping หรือยัด arp ก็แล้วแต่ แต่ต้องให้ mikrotik เจอ อย่างน้อย ๆ ก็ต้อง ping ได้
2. login จะใช้ hotspot หรือ ppp ก็ได้
3. ลองเข้าไปหา modem เลยว่าเข้าได้หรือเปล่า
4. ถ้าไม่ได้ก็ไปที่ firewall > mangle แล้วก็ add dst เป็นของ modem ตั้ง action เป็น accept

ปล. ระวังว่าเราเข้าได้ คนอื่นก็เข้าได้เหมือนกัน อย่าลืมป้องกันไว้ด้วยละ
บันทึกการเข้า
CommanddeR
บุคคลทั่วไป
« ตอบ #3 เมื่อ: มีนาคม 05, 2010, 01:47:26 AM »

รูปหน่อยแล้วกัน เดี๋ยวงง นอนแล้วเด้อ ถ้ายังงงอยู่เดี๋ยวมาอธิบายเพิ่ม

10.3.3.0/24 เป็น local hotspot
192.168.1.254 เอาไว้ติดต่อ ubuntu
192.168.2.254 เอาไว้ติดต่อ modem 1,2
192.168.3.254 เอาไว้ติดต่อ modem 3
192.168.4.254 เอาไว้ติดต่อ modem 4



ก็ประมาณนี้แหละ

« แก้ไขครั้งสุดท้าย: มีนาคม 05, 2010, 02:01:55 AM โดย CommanddeR » บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #4 เมื่อ: มีนาคม 05, 2010, 03:28:59 PM »

ขอบคุณครับ ผมก็คิดว่ามันไม่ยากอะไร
แต่ทำไมไม่ได้ก็ไม่รู้ครับ
ตอนนี้ ใช้ tool -> ping ใน winbox เพื่อ test ดู
ปรากฎว่า ping ไม่เจอครับ แต่ถ้าติ๊กเลือกเป็น arp ping จะเจอ

ปล. ผมทำ port นั้นเป็น dhcp client ทำให้ได้ ip จาก modem ครับ set address แบบ static ก็ไม่ได้เหมือนกัน
บันทึกการเข้า
CommanddeR
บุคคลทั่วไป
« ตอบ #5 เมื่อ: มีนาคม 05, 2010, 04:01:38 PM »

เอา mac กับ ip ของ modem ไปใส่ไว้ใน ip > arp เลยครับ ตัดปัญหาเรื่อง mikrotik หา modem ไม่เจอ
บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #6 เมื่อ: มีนาคม 05, 2010, 04:25:28 PM »

ตอนนี้ mikrotik เจอ modem แล้วครับ
ใน interface property ผมไปเลือก arp เป็น reply-only ไว้
พอเลือกเป็น enable ก็เจอเลย

ping จากหน้า winbox ได้ แต่จากใน network ยังไม่ได้เลย ฮืม
บันทึกการเข้า
CommanddeR
บุคคลทั่วไป
« ตอบ #7 เมื่อ: มีนาคม 05, 2010, 05:55:37 PM »

4. ถ้าไม่ได้ก็ไปที่ firewall > mangle แล้วก็ add dst เป็นของ modem ตั้ง action เป็น accept

ทำหรือยัง
บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #8 เมื่อ: มีนาคม 05, 2010, 06:01:08 PM »

ทำแล้วครับ
ทุกๆ ครั้งที่ลอง ping ก็จะเห็นว่าจำนวน packet เพิ่มขึ้น

นี่เป็นตาราง Routes ของผมครับ ดูๆ แล้ว ไม่น่าผิดปกติ


ปล. ผมว่าเป็นปัญหาเรื่อง routing เพราะ pptp เข้ามา ก็เข้าใช้ service เครื่องใน network ไม่ได้  ร้องไห้
« แก้ไขครั้งสุดท้าย: มีนาคม 05, 2010, 07:28:08 PM โดย ZeroCoolZ » บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #9 เมื่อ: มีนาคม 07, 2010, 04:16:39 PM »

ใครแนะนำได้ ช่วยผมหน่อยครับ
เท่าที่เช็คเจอ แม่แต่ network คนละวงกัน
192.168.2.0/24 กับ 192.168.3.0/24
ก็ ping หากันไม่เจอเลย

192.168.2.0/24 วงนี้ใช้ ether4-5 แล้ว bridge กัน
192.168.3.0/24 วงนี้ใช้ ether3

ทุกวง ใช้ net จาก PPPoE1 และ PPPoE2 ได้ตามปกติ ซึ่งอยู่บน ether1 และ ether2 ตามลำดับ
จนปัญญาจริงๆ ครับ ดูเหมือนง่ายๆ แต่แก้ไม่ได้มาหลายวันแล้ว ร้องไห้
บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #10 เมื่อ: มีนาคม 15, 2010, 04:39:55 PM »

ยังแก้ไม่ได้เลย หามาเป็นอาทิตย์แล้ว
network แต่ละวง ติดต่อกันไม่ได้เลย ร้องไห้
ทำ nat ก็ไม่ได้ ไม่รู้ติดตรงไหน ใครช่วยแนะนำหน่อย
บันทึกการเข้า
CommanddeR
บุคคลทั่วไป
« ตอบ #11 เมื่อ: มีนาคม 16, 2010, 12:25:12 AM »

ขอรายละเอียดหน่อย ทั้งสองวง set ค่ายังไง เช่นปล่อย dhcp หรือแบบ fix ip แล้วใน address set ไว้ยังไงบ้าง  ip เครื่องลูกอยู่ช่วงไหน ip router อยู่ช่วงไหน ต่อกันยังไงบ้าง

ผมก็ไม่รู้ว่า set ไว้ยังไงนะ แต่เปิด arp ไปเลย ให้มันได้ก่อน ได้แล้วค่อยมาปิด แบบว่าของผม set เสร็จแล้วใช้ได้เลย ไม่ได้แก้อะไรเพิ่มเติมมากนัก ติดต่อกันได้ทุกวงเลย ปัญหาที่ผมเจอ ส่วนใหญ่จะติดปัญหาตรงที่ mikrotik ไม่มี arp ของเครื่องลูก มันเลยติดต่อกันไม่ได้ อันที่ผมทำไม่ได้คือ ให้ติดต่อคนละวงผ่านทาง pptp กับ ทำให้ ip อีกวงติดต่อไปยัง router อีกวง โดยที่ไม่ต้องใช้ ip ของ mikrotik ก็เช่น 192.168.2.0/24 จะติดต่อไปยัง 192.168.1.1 แทนที่ 192.168.1.1 จะได้รับ ip ที่ติดต่อคือ 192.168.2.0/24 แต่ดันเป็น 192.168.1.254 ซึ่งเป็นของ mikrotik เอง ยังไม่รู้จะทำยังไงก็เลยปล่อย ๆ ไปก่อน เพราะกำลังศึกษาเรื่อง script ของ mikrotik อยู่ งงใช้ได้เลย
« แก้ไขครั้งสุดท้าย: มีนาคม 16, 2010, 12:34:45 AM โดย CommanddeR » บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #12 เมื่อ: มีนาคม 16, 2010, 12:57:31 AM »

Eth1
- Fix IP 192.168.0.2/24 (เพราะ modem ของ linksys ไม่ปล่อย DHCP ใน bridge mode)
- แก้ข้างบน ถ้าเลือกเป็น bridge mode only จะเป็น dhcp ไม่ได้ แต่ถ้าเลือก RFC1493 bridge จะเปิด dhcp ได้ครับ
  ตอนนีเป็น DHCP จาก modem ได้ ip 192.168.0.2
- ต่อกับ Modem 192.168.0.1 เพื่อใช้ต่อ PPP1

Eth2
- DHCP จาก modem ได้ ip 192.168.1.2
- ต่อกับ Modem 192.168.1.1 เพื่อใช้ต่อ PPP2

Eth3
- 192.168.3.1 ใช้เป็น DMZ เพื่อวาง Server กล้องวงจรปิด
- ปล่อย DHCP 192.168.3.2-192.168.3.254

Eth4-5
- Bridge กันเป็น 192.168.2.1 ชื่อ Apartments เพื่อจ่ายให้ลูกค้า
- ปล่อย DHCP 192.168.2.2-192.168.2.254
- เปิด Hotspot

ทำ Nat (Masquerade) PPP1 และ PPP2
Routes list เป็นดังนี้



ทุก port เป็น ARP เป็น Enable หมดแล้วครับ
ผมใช้เครื่อง 192.168.3.2 ใน Eth3 เป็นหลักในการทดสอบ (ในรูป routes list ไม่ได้ต่อไว้ เลยเป็น unreachable)
ไม่สามารถติดต่อกับ port ใดๆ ได้เลย (ยกเว้น ip ของ mikrotik ทุกๆ port สามารถติดต่อได้)
ตอนที่ได้มา ผมไม่ได้ reset config ไม่รู้เกี่ยวรึเปล่าครับ

ปล. ที่คุณ CommanddeR บอกว่ายังทำไม่ได้ ก็คล้ายๆ กับของผม
แต่ยังดีที่ของคุณ CommanddeR ใช้ Masquerade ได้นะครับ
ของผมไม่ได้เลย ร้องไห้
« แก้ไขครั้งสุดท้าย: มีนาคม 16, 2010, 06:36:09 PM โดย ZeroCoolZ » บันทึกการเข้า
CommanddeR
บุคคลทั่วไป
« ตอบ #13 เมื่อ: มีนาคม 16, 2010, 04:59:00 PM »

งั้นแสดงว่า mikrotik เห็นทุกเครื่อง ติดต่อได้หมด แต่เครื่องลูกติดต่อกันเองไม่ได้ใช่หรือเปล่าครับ







ผมก็ไม่ได้ทำอะไรพิศดารกว่านี้แล้วนะ ผมทำแค่ "firewall > mangle แล้วก็ add dst เป็นของ modem ตั้ง action เป็น accept" แค่นั้นเอง ก็ใช้ได้แล้ว แต่ต้องผ่าน masquerade ของ nat มาก่อน

สงสัยต้อง file > backup ตามด้วย sys > reset อิอิ

หรือของผมเป็น routeros x86 แต่ผมว่าไม่น่าจะเกี่ยวนะ จะ platform ไหนก็ routeros เหมือนกัน น่าจะได้เหมือนกันนิ
« แก้ไขครั้งสุดท้าย: มีนาคม 16, 2010, 05:05:49 PM โดย CommanddeR » บันทึกการเข้า
ZeroCoolZ
Level 4 (WISP)
****
กระทู้: 114


กทม.ร้อน มาเที่ยวภูเก็ตกันดีกว่า ^^


เว็บไซต์
« ตอบ #14 เมื่อ: มีนาคม 16, 2010, 05:11:53 PM »

ได้แล้วครับ ขอบคุณมากๆ เลย ยิงฟันยิ้ม
จริงๆ ผมก็ลองทั้ง 2 ขั้นตอนแล้ว คือ
1. Add ใน Firewall->Mangle ให้ accept
2. สร้าง Nat สำหรับตอนออกไปทาง Eth1 และ Eth2
แต่...... ผมลองแค่ทีละอย่างครับ ไม่ได้ลองพร้อมกัน 555+

ปล. สำหรับท่านที่จะทำตาม อย่าลืมว่า หลังจาก Add แล้ว ให้ลากไปไว้บนสุดด้วยนะครับ (กันพลาด) ยิ้มเท่ห์
บันทึกการเข้า
หน้า: [1] 2
  ส่งหัวข้อนี้  |  พิมพ์  
 
กระโดดไป:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.10 | SMF © 2006-2009, Simple Machines LLC | Thai language by ThaiSMF Valid XHTML 1.0! Valid CSS!
หน้านี้ถูกสร้างขึ้นภายในเวลา 0.121 วินาที กับ 16 คำสั่ง